Logo Logo
/// 

AviSynth und VirtualDub - kein Ton



Noch was unklar? Dann in unserem Forum nachfragen!


Frage von Jens Peter Moeller:


Hallo Zusammen,

ich habe hier zwei AVIs, aufgenommen mit einer Digital-Foto-Kamera,
bekommen. Komischerweise sind die um 90° gedreht, aber nur das Bild,
nicht das Format (;640x480). Wie man so aufnehmen kann, ist mir ein
Rätsel. Aber egal, mit VirtualDub kann ich das beheben.
Mit dem Programm beschäftige ich mich jetzt zum ersten Mal. Weil es
die AVIs nicht direkt öffnen kann, habe ich noch AviSynth zur Hilfe
genommen:
DirectShowSource(;"C:...CIMG2360.AVI")

Und hier liegt schon das Problem, denke ich. Bei VirtualDub kommt
nämlich nur das Video an, kein Ton. Was mache ich falsch, wie geht
es richtig?
Die AVIs haben laut GSpot übrigens folgende Formate.
Video: M4S2 - Fully Compliant MPEG-4 v2 simple profile codec
Audio: dvi adpcm (;0x0011) Intel Corporation

Gruß
JPM




Antwort von Jens Peter Moeller:

Jens Peter Moeller schrieb:

> die AVIs nicht direkt öffnen kann, habe ich noch AviSynth zur Hilfe
> genommen:
> DirectShowSource(;"C:...CIMG2360.AVI")
>
> Und hier liegt schon das Problem, denke ich. Bei VirtualDub kommt
> nämlich nur das Video an, kein Ton. Was mache ich falsch,

Hier zu fragen, bevor ich mich eigehend mit der Doku beschäftigt
zu haben.

> wie geht es richtig?

video = DirectShowSource(;...)
audio = WavSource(;...)
AudioDub(;video, audio)

Gruß
JPM





Noch was unklar? Dann in unserem Forum nachfragen!


Antworten zu ähnlichen Fragen:
Ton von AVI zu leise
AVI: Ton raus, Film endlos wiedergeben
Ton aus AVI extrahieren mit Kommandozeilentool?
AviSynth und VirtualDub - kein Ton
Kodierung von AVI nach MPG ohne Ton - warum?
12 GB AVI ohne Ton?
DaVinci Resolve 15: kein Ton nach Windows update
DaVinCi Resolve 15: Ton nur kurz da, dann weg?
DaVinci Resolve 12.5 auf meinem Rechner kein Ton, auf anderen ja - was tun?
Kein Ton bei Export in Avi
AVI nur Ton
AVI und kein Ton
Filter/Script für VirtualDub/AVISynth
Kein Capturen mit VirtualDub und Terratec Cinergy 400 TV
MoreTV und XP: kein Ton
Terratec und Linux, kein Ton...
TV-Karte plötzlich kein Bild und Ton
TT Budget DVB-C: Kein Bild und Ton
IrfanView und AVI: Ton da, aber kein Bild
Videoclip: kein Ton; wie Audiocodec finden und installieren?
Aldi-PC und DVB-S. Ton, Videotext, EPG aber kein Bild
Atomos Shogun und Ninja bekommen kein Ton vom Lenovo Thinkpad
Ein Drehbuch ist kein Roman -- schreiben mit Bild und Ton
Hi8 nach DVD unter XP nur schwarz/weiß und kein Ton??
Bitte um Hilfe: Kein Bild, aber Ton bei MPEG2 und Media Player Classic
VirtualDub: Merkwürdige Ton-Asynchronität nach XViD/MP3-Kompression?

















weitere Themen:
Spezialthemen


16:9
3D
4K
AI
ARD
ARTE
AVCHD
AVI
Adapter
Adobe After Effects
Adobe Premiere Pro
After effects
Akku
Akkus
Apple
Apple Final Cut Pro
Audio
Aufnahme
Aufnahmen
Avid
Avid Media Composer
Band
Bild
Bit
Blackmagic
Blackmagic DaVinci Resolve
Blackmagic Design DaVinci Resolve
Blende
Book
Brennen
Cam
Camcorder
Camera
Canon
Canon EOS
Canon EOS 5D MKII
Canon EOS C300
Capture
Capturing
Cinema
Clip
ClipKanal
Clips
Codec
Codecs
DSLR
Datei
Digital
EDIUS
ENG
EOS
Effect
Effekt
Effekte
Empfehlung
Euro
Export
Fehler
Festplatte
File
Film
Filme
Filmen
Filter
Final Cut
Final Cut Pro
Format
Formate
Foto
Frage
Frame
GoPro
Grass Valley Edius
HDMI
HDR
Hilfe
Import
JVC
KI
Kabel
Kamera
Kanal
Kauf
Kaufberatung
Kaufe
Kaufen
Kurzfilm
Layer
Licht
Light
Live
Lösung
MAGIX video deLuxe
MPEG
MPEG-2
MPEG2
Mac
Magix
Magix Vegas Pro
Menü
Mikro
Mikrofon
Mikrophone
Monitor
Movie
Musik
Musikvideo
NAB
Nero
News
Nikon
Objektiv
Objektive
PC
Panasonic
Panasonic GH2
Panasonic HC-X1
Panasonic S1 mit V-Log
Panasonic S5
Pinnacle
Pinnacle Studio
Player
Plugin
Plugins
Premiere
Produktion
Projekt
RAW
RED
Recorder
Red
Render
Rendern
Schnitt
Software
Sony
Sony HDR
Sound
Speicher
Stativ
Stative
Streaming
Studio
TV
Test
Titel
Ton
USB
Umwandeln
Update
Vegas
Video
Video-DSLR
Videos
Videoschnitt
Windows
YouTube
Zoom