Infoseite // Bitte um Hilfe: Kein Bild, aber Ton bei MPEG2 und Media Player Classic



Frage von Detlef Wirsing:


Hallo zusammen.

Ich benutze den Media Player Classic v6.4.5.6, der mir bisher immer
gute Dienste leistete. Auf einmal spielt er keine MPEG2 Filme mehr ab,
bzw. nur den Ton - das Bild ist schwarz. Das ist sehr verdrießlich,
weil ich in diesem Format von der D-Box 2 aufnehme. :-)

Ich habe an meiner Konfiguration nichts geändert und kann den Fehler
nicht finden. Der "moderne" Media Player funktioniert, aber den möchte
ich eigentlich nicht benutzen. Kann mir jemand einen Tip geben, was
passiert sein könnte und wie ich mein Bild wiederbekomme?

Mit freundlichen Grüßen
Detlef



Space


Antwort von Matthias Berke:

Detlef Wirsing wrote:

> Ich benutze den Media Player Classic v6.4.5.6, der mir bisher immer
> gute Dienste leistete. Auf einmal spielt er keine MPEG2 Filme mehr ab,
> bzw. nur den Ton - das Bild ist schwarz. Das ist sehr verdrießlich,
> weil ich in diesem Format von der D-Box 2 aufnehme. :-)

Verwende mal eine neuere Version. (;Deutsch 6.4.6.7)
http://www.silent-dreams.de/prg-mpc.html

Matthias



Space


Antwort von Detlef Wirsing:

Matthias Berke schrieb am 5. September:

[...]
> Verwende mal eine neuere Version. (;Deutsch 6.4.6.7)
> http://www.silent-dreams.de/prg-mpc.html

Danke für den URL, Matthias. Ist bereits installiert und funktioniert
vorzüglich. Nun kann die Arbeit weitergehen.
:-)

Trotzdem seltsam, daß die alte Version auf einmal kein Bild mehr
brachte. Aber was solls? Das Bessere ist der Feind des Guten.

Mit freundlichen Grüßen
Detlef



Space


Antwort von Matthias Berke:

Detlef Wirsing wrote:

> Danke für den URL, Matthias. Ist bereits installiert und funktioniert
> vorzüglich. Nun kann die Arbeit weitergehen.
> :-)

Bitte gerne. Danke für die Rückmeldung.

Matthias



Space


Antwort von Detlef Wirsing:

Matthias Berke schrieb am 5. September:

> Detlef Wirsing wrote:
>
> > Danke für den URL, Matthias. Ist bereits installiert und funktioniert
> > vorzüglich. Nun kann die Arbeit weitergehen.
> > :-)
>
> Bitte gerne. Danke für die Rückmeldung.

Zur Erinnerung: Inzwischen habe ich den Media Player Classic
6.4.6.7(;MPC) deutsch installiert.

Leider habe ich mich zu früh gefreut. Zwar werden MPEG2 Dateien
gespielt, aber meine DVDs nicht mehr. Ich starte die Wiedergabe von
Platte, indem ich die Datei Video ts.ifo doppelklicke und im
erscheinenden Menü aussuche, was ich sehen möchte. Normkonforme
VOB-Dateien mit z.B. einer Auflösung von 720x576 sind dabei kein
Problem, aber die von mir zum Authoring von 480x576 auf 352x576 und
nachher im VOB-Format wieder auf 480x576 zurückgepatchten Videos haben
zwar Ton, aber es wird kein Bild angezeigt. Genauer gesagt bleibt das
Bild des jeweiligen Menüs stehen, während der Ton des gwählten
Kapitels korrekt wiedergegeben wird.

Wenn ich die zum nicht angezeigten Film gehörige IFO-Datei starte,
also z.B. Vts 02 0.ifo, wird der Film dargestellt. Gehe ich über das
Hauptmenü, tritt obiges Problem auf. Da ich bis gestern meine eigenen
Aufnahmen vor dem Brennen mit dem MPC auf Fehler überprüft habe, und
bis dahin seit Monaten alles reibungslos funktionierte, bin ich
ratlos.

Ich habe den Eindruck, daß ich irgendein Problem mit den Codecs habe,
ohne daß ich etwas geändert hätte. Power DVD funktioniert übrigens,
aber das ist für meine Zwecke zu umständlich zu bedienen. Die im MPC
angegebene Homepage zur Hilfe ist leider "under construction".

Kann mir jemand einen Tip geben, wie ich die Fehlerursache
lokalisieren kann? Gibt es vielleicht sowas wie ein Testprogramm für
die installierten Codecs? Betriebssystem ist Windows 2000
professional, falls das eine Rolle spielen sollte.

Mit freundlichen Grüßen
Detlef Wirsing



Space


Antwort von Matthias Berke:

Detlef Wirsing wrote:

> Zur Erinnerung: Inzwischen habe ich den Media Player Classic
> 6.4.6.7(;MPC) deutsch installiert.
>
> Leider habe ich mich zu früh gefreut. Zwar werden MPEG2 Dateien
> gespielt, aber meine DVDs nicht mehr.
...
> Kann mir jemand einen Tip geben, wie ich die Fehlerursache
> lokalisieren kann? Gibt es vielleicht sowas wie ein Testprogramm für
> die installierten Codecs? Betriebssystem ist Windows 2000
> professional, falls das eine Rolle spielen sollte.

Ich gehe davon aus Du hast für Dein WINDOWS alle aktuellen Patches in
Windows Update unter "Wichtige Updates und Service Packs" installiert!

1.
"Windows Media Player"
Downloads Upates, DirectX Updates, Codecs, Tipps und Hilfeseiten
http://home.arcor.de/heinrich.christine/matthias/index.htm

2.
Falls Du DVD-Player "InterVideo XPack" oder WIN-DVD verwendest, kannst
Du bei deren Support nachschauen ob sie eine Lösung für Dein Problem
haben/kennen. http://www.intervideo.com/jsp/Home.jsp

3.
Falls gekaufte DVD:

Du bist sicher das der richtige Ländercode für die DVD eingestellt ist?
Vorsicht, Du kannst den Ländercode nur max. 5 mal wechseln, danach
bleibt die letzte Ländercode-Einstellung bestehen. Ändern ist dann nicht
mehr möglich.

Ausnahmen:
das CD/DVD-LW lässt sich mit einer Ländercodefreien Firmware patchen.

http://www.animelayer.net/animedvds/index.php?way%need
oder
http://www.pctip.ch/helpdesk/kummerkasten/archiv/div/17425.asp

Webseite für Firmware (;offiziel/inoffiziell) zu allen Herstellern
http://forum.rpc1.org/portal.php

ACHTUNG - WARNUNG!
------------------
Bei Verwendung von Firmware die nicht offiziell vom Hersteller
freigegeben wurde, verlierst Du jeglichen Anspruch auf
Garantie/Gewährleistung/kostenlosem Support.

4.
Was ich an Problemlösungen kenne:

"Mediaplayer und DVD's"
http://www.pc-experience.de/wbb2/thread.php?threadid221&sidUb10be4f3a04b35c99f174820c57d49

Windows Media Player erkennt DVD nicht oder spielt DVD nicht ab
(;Die Lösungen in Reihenfolge durchgehen)
http://support.microsoft.com/?id09321

"Fehlerbehandlung von DVD-Problemen in Windows 2000"
http://support.microsoft.com/?id$9334

oder
http://support.microsoft.com/search/default.aspx?InCC hdn%True&QuerySource%gASr Query&Catalog%LCID1031&CDIDDE-KB&PRODLISTSRCON&Product%winxpGer&Queryc%DVD&Query%DVD&KeywordType%ALL&maxResults0&Titlesúlse&numDays=&InCC%on
(;Falls nicht korrekt umgebrochen, den Link hintereinanderkopieren)

Matthias



Space


Antwort von Detlef Wirsing:

Matthias Berke schrieb am 6. September:

> Detlef Wirsing wrote:
[...]
> > Leider habe ich mich zu früh gefreut. Zwar werden MPEG2 Dateien
> > gespielt, aber meine DVDs nicht mehr.
[...]
> Ich gehe davon aus Du hast für Dein WINDOWS alle aktuellen Patches in
> Windows Update unter "Wichtige Updates und Service Packs" installiert!

Ja. Und selbst wenn nicht: Am Abend funktionierte alles, am nächsten
Morgen nicht mehr. Der Rechner lief durch, Änderungen wurden nicht
vorgenommen.

Ich werde die Ingrid machen und zur Beantwortung deiner Fragen, soweit
angebracht, mich selbst zitieren.

> 1.
> "Windows Media Player"
> Downloads Upates, DirectX Updates, Codecs, Tipps und Hilfeseiten
> http://home.arcor.de/heinrich.christine/matthias/index.htm

Danke für den URL, ich werde nachschauen, ob ich dort eine Lösung für
mein Problem finde.

> 2.
> Falls Du DVD-Player "InterVideo XPack" oder WIN-DVD verwendest, kannst
> Du bei deren Support nachschauen ob sie eine Lösung für Dein Problem
> haben/kennen. http://www.intervideo.com/jsp/Home.jsp

Im letzten Artikel schrieb ich dazu:
| Power DVD funktioniert übrigens, aber das ist für meine Zwecke
| zu umständlich zu bedienen.

> 3.
> Falls gekaufte DVD:

Im letzten Artikel schrieb ich dazu:
| Da ich bis gestern meine eigenen Aufnahmen vor dem Brennen
| mit dem MPC auf Fehler überprüft habe, und bis dahin seit
| Monaten alles reibungslos funktionierte, bin ich ratlos.

Es handelt sich ausschließlich um eigene Aufnahmen von der D-Box 2.
Die von öffentlich rechtlichen Sendern stammenden, normkonformen Filme
mit 720x576 werden fehlerfrei abgespielt. Bei den Aufnahmen von
Premiere, die meist im Format 480x576 gesendet werden, benutze ich den
DVD-Patcher, um sie ins von beliebigen Authoring Programmen
akzeptierte Format 352x576 zu patchen. Nach dem Authoring patche ich
die entsprechenden VOB-Dateien auf 480x576 zurück. Der eigentliche
Film, also die VOB-Datei, läßt sich dann zwar korrekt abspielen. Aber
wenn ich über das Menü gehe, wird der entsprechende Ton des Kapitels
abgespielt, nicht aber das Bild. Stattdessen bleibt das Menübild
stehen.

> Du bist sicher das der richtige Ländercode für die DVD eingestellt ist?
> Vorsicht, Du kannst den Ländercode nur max. 5 mal wechseln, danach
> bleibt die letzte Ländercode-Einstellung bestehen. Ändern ist dann nicht
> mehr möglich.

Ich besitze keine einzige Kauf-DVD. Aber inzwischen 150 DVDs mit
eigenen Aufnahmen. Noch nie hatte ich den beschriebenen Fehler.

> Ausnahmen:
> das CD/DVD-LW lässt sich mit einer Ländercodefreien Firmware patchen.
[...]

Der Ländercode kann es nicht sein, aber trotzdem danke für die Tips.
Vielleicht kann ich später einmal einen der Patches gebrauchen. Für
meinen Stand-Alone Player von Sony habe ich schon mal was gefunden,
aber dafür benötigt man eine programmierbare Fernbedienung. Bei dem
Anschaffungspreis ist es günstiger, sich für jeden Ländercode einen
eigenen Player zu kaufen.

> 4.
> Was ich an Problemlösungen kenne:
[...]

Ich werde das alles überprüfen. Trotzdem bin ich der Meinung, daß bei
mir ein Problem mit dem Codec vorliegt. Dafür spricht, daß der
Austausch des Media Players Classic nicht dazu führte, daß alles wie
vorher funktioniert. Gibt es keine Möglichkeit, die installierten
Codecs zu überprüfen?

Vielen Dank für deine Hilfe.
Detlef

PS: Update direkt vor dem Losschicken:
Ich habe mir jetzt auch noch den MPC 6.4.8.2 besorgt, und der
funktioniert. Zumindest macht er keinen der bisher beschriebenen
Fehler. Ich werde die Sache ausgiebig testen. Verstehen tu ich das
alles allerdings nicht.

Mit freundlichen Grüßen
Detlef Wirsing

--
Wer in der de.*-Hierarchie keinen Realnamen
und/oder keine replyfähige E-Mail Adresse ver-
wendet, darf nicht mit einer Antwort rechnen.


Space


Antwort von Klaus Bregel:

Für deine Codec-Probleme:
http://www.headbands.com/gspot/
gibt infos über alle installierten codecs

hth


Space


Antwort von Matthias Berke:

Detlef Wirsing wrote:

Hallo Detlev,

> Ja. Und selbst wenn nicht: Am Abend funktionierte alles, am nächsten
> Morgen nicht mehr. Der Rechner lief durch, Änderungen wurden nicht
> vorgenommen.
>
> Ich werde die Ingrid machen und zur Beantwortung deiner Fragen, soweit
> angebracht, mich selbst zitieren.

War nur als Übersicht für Dich gedacht was *ich* so an Ansatzpunkten
habe. Ich hatte es nicht extra an dich angepasst, sondern einfach
komplett gesendet. Hätte ich erwähnen sollen. Sorry, wenn ich Dich da
durcheinander gebracht habe.

>> 1.
>> "Windows Media Player"
>> Downloads Upates, DirectX Updates, Codecs, Tipps und Hilfeseiten
>> http://home.arcor.de/heinrich.christine/matthias/index.htm
>
> Danke für den URL, ich werde nachschauen, ob ich dort eine Lösung für
> mein Problem finde.

Deine Frage zu Codecs findest Du dort sicher ausführlich beantwortet.
Auch den Hinweis zum Überprüfen/ermitteln von Codecs mit "GSpot" wie ihn
Dir Klaus gab findest Du dort auch.

> PS: Update direkt vor dem Losschicken:
> Ich habe mir jetzt auch noch den MPC 6.4.8.2 besorgt, und der
> funktioniert. Zumindest macht er keinen der bisher beschriebenen
> Fehler. Ich werde die Sache ausgiebig testen. Verstehen tu ich das
> alles allerdings nicht.

Sind sicherlich die aktuelleren Codecs drin.

Nochmals Sorry für die kleine Verwirrung.
Gruß
Matthias



Space



Space


Antwort von Detlef Wirsing:

Matthias Berke schrieb am 7. September:

[...]
> Auch den Hinweis zum Überprüfen/ermitteln von Codecs mit "GSpot" wie ihn
> Dir Klaus gab findest Du dort auch.

Gspot hatte ich vorher schon installiert. Allerdings bin ich mir nicht
ganz im klaren darüber, was ich mit den Ergebnissen, bzw. nicht
vorhandenen Ergebnissen, anfangen soll. Zwar werden mir die für Direct
Show benötigten und installierten Codecs angezeigt, aber ansonsten
steht überall "n/a", was wohl für "not available" stehen soll.

[...]
> > PS: Update direkt vor dem Losschicken:
> > Ich habe mir jetzt auch noch den MPC 6.4.8.2 besorgt, und der
> > funktioniert. Zumindest macht er keinen der bisher beschriebenen
> > Fehler. Ich werde die Sache ausgiebig testen. Verstehen tu ich das
> > alles allerdings nicht.
>
> Sind sicherlich die aktuelleren Codecs drin.

Es kann ja nicht angehen, daß derselbe Film, den ich gestern noch
abspielen konnte, heute neue Codecs benötigt. Deshalb meine Vermutung,
daß das Problem von einer, aus welchen Gründen auch immer,
zerschoßenen Codec-Installation herrührt. Daß es mit der neuesten
Version des MPC wieder funktioniert spricht nicht dagegen, denn laut
Beschreibung bringt diese ihren eigenen MPEG2 Decoder mit.

Bisher konnte ich beim MPC 6.4.8.2 übrigens keinen Fehler feststellen.
Er verhält sich exakt wie meine alte Version, die ewig lang völlig
fehlerfrei arbeitete, bis zu besagtem Tag halt.

> Nochmals Sorry für die kleine Verwirrung.

Da nicht für. Ich bin ja froh, daß mir jemand geholfen hat. Meine
Platten sind fast voll gewesen. Und alles, was das zügige Wegbrennen
der Daten verlangsamte oder verhinderte, mußte schnellstens beseitigt
werden. Inzwischen ist die Lage entspannter.

Mit freundlichen Grüßen
Detlef



Space


Antwort von Matthias Berke:

Detlef Wirsing wrote:

Hallo Detlef,

> Es kann ja nicht angehen, daß derselbe Film, den ich gestern noch
> abspielen konnte, heute neue Codecs benötigt. Deshalb meine Vermutung,
> daß das Problem von einer, aus welchen Gründen auch immer,
> zerschoßenen Codec-Installation herrührt.

Scheint zumidest so. zu sein. Welche Codecs man installieren sollte und
auch zur Reparatur von Codecs unter WIN 2000/XP, dazu findest Du eine
genaue Anleitung auf meiner Webseite.

Lese die Seite einfach nochmal ganz in Ruhe. Ich weiß ja selbst, in der
Aufregung überliest man mal schnell was, aber jetzt kannst Du es ja
ruhiger angehen. ;-)

Achte auch mal die Problemlösungen in der
"Mini-FAQ" aus de.comp.tv video (;sehr empfehlenswert)
http://home.arcor.de/heinrich.christine/matthias/index.htm#codec-Links

Matthias



Space



Antworten zu ähnlichen Fragen //


mpeg2: bild und ton zusammenführung im streamclip funktioniert nicht
Win Media Player 7/1 kein Bild nur Ton
bei media player 9 läuft nur ton kein bild
Real Player 10: Ton, aber kein Bild
DVDLab Probleme in Bild und Ton beim abspielen im Stand alone Player
VLC Media Player ---> nur Ton kein Bild
kein bild nur ton bei windows media player v.11
windows media player 11 KEIN Bild - nur Ton!
Nicht-DVD-konforme MPEGs mit DVD-lab zusammengesetzt: Bild da, aber kein Ton! Hilfe!
Bild mit Media player classic strecken
Media Player 6.4. bring System zum Absturz...bitte Hilfe (Codecproblem?)
Falsches Seitenverhältnis bei Media Player Classic 6.4.5.6
Windows Media Player 7: Ton, aber schwarze Bildfläche
Media Player Classic: nur ein Problem
Media Player Classic Tonversatz nach spulen
Audio umschalten im Media Player Classic
"Media Player Classic" stoppt nach jedem Titel?!
DVB-T-Aufnahmen mit Media Player Classic abspielen?
*.mov-Datei mit Media-Player-Classic
Aldi-PC und DVB-S. Ton, Videotext, EPG aber kein Bild
IrfanView und AVI: Ton da, aber kein Bild
Kann DVD nur unter VLC Media Player abspielen, doch Bild und Ton "ruckeln"
Kein Ton bei zusammengesetzter MPEG2-Datei
DJI Mavic 3 Classic: Deutlich billiger als Mavic 3, aber selbe Hauptkamera
Kein Bild, nur Ton bei Aufnahmeversuch durch Composite In
Neues im Avid Media Composer 2023.8 - u.a. Transkription und Classic Layout




RSS Facebook Twitter slashCAM-Slash