medienonkel
Beiträge: 414

GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von medienonkel » Sa 06 Aug, 2022 10:38

Hallo in die Runde.

Ich stehe hier gerade vor einem echten Rätsel:
Wollte auf ne RTX 3060 aufrüsten, musste dann aber feststellen, dass sich die Leistung (Benchmark: V-Ray Benchmark) bzgl. CUDA sogar verschlechtert hat. Was zum üblichen Quercheck mit nem anderen Rechner geführt hat.
Ergebnis:
Die zwei 12 Jahre alten Xeons sind komplett veraltet, auf nem Ryzen 7 bringt die RTX 3060, was sie bringen soll, nämlich die doppelte Leistung, als ne 1070ti.
In der Xeon Maschine steckt nun wieder die 1070ti. Die bringt aber nun sogar weniger Leistung, als vorher!

Nun aber zum von mir zufällig festgestellten Phänomen:
Wenn ich auf der alten Xeon Maschine Resolve minimiert mit geladenem Projekt offen habe, bringt die 1070ti im V-Ray GPU Benchmark die der Karte angemessenen knapp 400 vpaths ("Punkte").

Habe ich Resolve hingegen nicht geöffnet schafft die 1070ti nur knapp 100 vpaths!

Dieses Verhalten ist absolut zu 100% reproduzierbar.
Resolve an: 390-430 vpaths
Resolve aus: 90-120 vpaths
Alleine die Inkonsistenz der Werte ist natürlich auch schon merkwürdig.

Es scheint, als ob Windows irgendeine Komponenten von Resolve braucht, um die GPU korrekt zu nutzen... dieses Verhalten widerspricht so ziemlich allem, was logisch wäre. Im Taskmanager ist die GPU immer zwischen 95 und 100 Prozent ausgelastet. Ob mit oder ohne Resolve.
Eigentlich sollte Resolve ja Leistung abzwacken und nicht grundlegend nötig sein, damit eine andere Software überhaupt ordentlich läuft.

Treiber habe ich mehrfach komplett deinstalliert (Guru3D tool) und verschiedene Versionen ausprobiert. Bringt alles nix.
Vor einer kompletten Windows Neuinstallation schrecke ich gerade zurück, weil ich überlege, die Xeon Kiste gleich in Rente zu schicken...

Kennt jemand so ein Verhalten?
Zuletzt geändert von medienonkel am Sa 06 Aug, 2022 12:36, insgesamt 1-mal geändert.




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve

Beitrag von klusterdegenerierung » Sa 06 Aug, 2022 10:58

Deine eigenen Referenzwerte kann ich so gar nicht nachvollziehen, Deine Messerergebnisse dafür schon!

Was daran liegt, das die 3060 von der Perfomance Einordnung rein theoretisch unter der 1070ti angesiedelt ist, denn die ersten 2 Stellen sind ja nur die Generation und die beiden letzten stehen für Rangliste und Performance.

So wäre also eine RTX3070ti evtl. doppelt so schnell wie eine RTX3060, aber auf keinen Fall so wie in Deinem Fall.
Da geht es eher darum, das die RTX eine neuere Architektur und Chipsatz verwendet als die GTX und deshalb etwas die Nase vorne hat.

Die Cuda Werte sind vielleicht doppelt so hoch, dafür verwendet die 1070ti aber eine 256Bit Architektur.
https://www.techpowerup.com/gpu-specs/g ... 0-ti.c3010
https://www.techpowerup.com/gpu-specs/g ... 3060.c3682

Ich denke nicht das Du Deine erhoffte Verdoppelung erreichen wirst, vor allem weil Resolve sich nicht wirklich für Cuda interessiert.
https://gpu.userbenchmark.com/Compare/N ... 4105vs3943

Ein Plus von 2% ist nicht sonderlich erstrebenswert, weshalb ich bei meiner 1080 bleibe.
Was es damals bei mir richtig gebracht hat war, der upgrade von GTX970 auf GTX1080, das war der Bringer.
https://gpu.userbenchmark.com/Compare/N ... 2577vs3603

Was richtig was gebracht hätte (in Bezug auf alte 1070ti) wäre eine gebrauchte 1080ti.
https://gpu.userbenchmark.com/Compare/N ... 3943vs3918

https://www.ebay-kleinanzeigen.de/s-anz ... -225-16748
"Niveau sieht nur von unten aus wie Arroganz!"




medienonkel
Beiträge: 414

Re: GPU Phänomen mit Resolve

Beitrag von medienonkel » Sa 06 Aug, 2022 11:40

Kann man so nicht sagen.
Das Update habe ich vor allem wegen der RTX und Tensor Einheiten gemacht, mit Hinblick auf 3d Rendering unter V-Ray, Arnold usw.
Die Rechnung war auch, mindestens die gleiche Leistung wie die 1070ti plus neue Features der RTX Serie in Kombination mit dem momentan recht guten Wiederverkaufswert der 1070ti (200-300 Euro), was mir effektiv ne aktuelle Karte für 100-200 Euro bringt.

Fakt ist auch, dass die 3060er auf meiner alten Plattform unterfordert vor sich hinrödelte.
Die 3060er bringt im Blackmagic RAW Speed Test im Xeon System knapp 500 fps in HD unter CUDA, im Ryzen 7 System gute 1100 fps.
Sogar die 1070ti war halt jetzt 4 Jahre lang im Xeon System (12 Jahre alte Architektur!) gut ausgebremst.

Wie du ja selbst sagst ist die 3060er zwei Generationen über der 1070er.
Im Puget Resolve Benchmark kam die 3060er sogar auf den vierfachen GPU-Effects Wert als die 1070ti.

Mit der 3060er lief die Magic Mask in Resolve in ner HD-Timeline fast in Echtzeit, die 1070er hat sich für jedes Frame eine halbe Gedenksekunde genehmigt.
Das sind schon wesentlich mehr, als 2% mehr Leistung.
Die 1070er hat ein 256 bit breites Speicherinterface, die 3060er 192 bit, das ist mir bewusst.
Trotzdem hat die 3060er nen Speicherdurchsatz von 360 Gbit/s, die 1070er 256 Gbit/s. Ist also sogar schneller angebunden bzw. zumindest nicht langsamer, also irrelevant.

Es ist keine erhoffte Verdoppelung, es ist eine Reale Verdoppelung ;-) Zumindest bei echten CUDA Anwendungen.
Gerne würde ich die 1070er mal ins Ryzen System stecken, leider passt das Riesending dort nicht ins Gehäuse.
Aber wie gesagt, evtl. bau ich heut noch nen komplett neuen Rechner auf.

Mein Post bezog sich aber eher auf das Phänomen, dass irgendwie die CUDA Leistung im V-Ray Benchmark im Xeon System nur abgerufen wird, wenn eine andere CUDA Anwendung parallel läuft (mit Video Enhancer AI parallel offen klappts nämlich auch...).
Auf dem Ryzen System tritt dieses Phänomen nämlich nicht auf. Geht also eher darum ob das nun ein Software oder ein Hardware-Problem ist (Netzteil, RAM oder einfach Altersschwäche...)

Ich finde es zumindest spannend.




Jasper
Beiträge: 504

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von Jasper » Sa 06 Aug, 2022 12:44

Schau dir die Auslastung der CPU mal an. Diese düfte wohl die neue Grafikkarte ausbremsen.
PCI Express 4.0 Steckplatz dürfte das Mainboard auch nicht haben.
Gruß Jasper




medienonkel
Beiträge: 414

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von medienonkel » Sa 06 Aug, 2022 13:19

Klar schau ich da drauf, ist bei dual-CPU Systemen nicht so einfach zu sagen. Teilweise ist die CPU-Last bei stabilen 20 Prozent auf allen Threads, während die GPU auf 100 ist.
Der Flaschenhals ist hier eher der Chipsatz des Boards und der RAM-Durchsatz. Ist ja noch DDR2 1333.... ;-)

Und klar, wie ich ja schon geschrieben habe, auf dem moderneren System läuft die 3060er wesentlich schneller, die 1070ti würde darauf sicherlich auch gehörig zu legen.
Ist ja Teil meiner grundlegenden Erkenntnis, dass das System nun hoffnungslos veraltet ist.
Das Mainboard hat nicht einmal USB3, geschweige denn Sata3, PCI Express ist selbstverständlich 2.0. Erklärt aber alles nicht das Verhalten, das ich hier beschrieben habe:

Dass bei V-Ray die Leistung bei CUDA um 75% einbricht, wenn ich nicht - getestet - Resolve, Video Enhance AI oder After Effects einfach nur gestartet habe und das absolut zuverlässig reproduzierbar ist.

Nur darum geht es hier. Ist natürlich auch möglich, dass der Benchmark fehlerhaft ist. Dafür läufts aber auf nem anderen Rechner unabhängig davon, was sonst so offen ist.

Den Unterschied, ob die Karte in PCI-E 3 oder vier steckt ist weitestgehend zu vernachlässigen, da der Ryzen 8 Kerner da dann schon wieder zu langsam wäre.

Und für ein Epyc-System fehlt mir für daheim die Kohle.




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von klusterdegenerierung » Sa 06 Aug, 2022 18:42

Was Du aufjeden mal machen solltest, wenn Du es nicht eh schon machst und Windows verwendest, das Du in den Nvidia 3D Settings Resolve als Programm hinzufügst und die 3D Option aktivierst und auf Leistung stellst und den Gaming quatsch abstellst, erst dann verwendet Resolve Deine GPU wirklich, voher wird gerne nur die CPU verwendet, die dann bis auf 100% geht und die GPU wenn überhaupt auf vielleicht max 20%.

Nach den Änderungen ist die GPU Aktivität beim rendern auf bis 80% gestiegen und die CPU ging runter auf 50%, das tat auch dem System richtig gut.
Danke noch mal für den guten Tipp an unseren Mickey aus Frankreich. :-)
"Niveau sieht nur von unten aus wie Arroganz!"




medienonkel
Beiträge: 414

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von medienonkel » So 07 Aug, 2022 12:26

Danke für den Tipp.
Aber CPU und GPU werden im taskmanager nun beidemit 2-3% Leistung angezeigt, wenn was rendert... Dauert aber trotzdem nicht länger...

Resolve ist mir eigentlich ziemlich egal gerade. Wie ich schon angenommen habe, hab ich erstmal ein neues System gebaut und installier erstmal heute Windows neu.

Da auch dort nun V-Ray nur schnell läuft, wenn was anderes im Hintergrund läuft. 3ds max rendert gar nix mehr.

Wenn das neue Windows nix hilft geb ich's auf und mach wieder lieber Sport :-)




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von klusterdegenerierung » So 07 Aug, 2022 16:39

OK, dennoch sollte wenn alles passend wäre, die GPU das rendern übernehmen, damit Dein Rechner nicht in die Knie geht und der Venti bläht wie hulle.
"Niveau sieht nur von unten aus wie Arroganz!"




Frank Glencairn
Beiträge: 16945

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von Frank Glencairn » Mo 08 Aug, 2022 08:27

Ich würde vor allem mal ein wirkliches Projekt rendern und das vergleichen, als irgendwelche Benchmarks.




medienonkel
Beiträge: 414

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von medienonkel » Mo 08 Aug, 2022 10:32

Frank Glencairn hat geschrieben:
Mo 08 Aug, 2022 08:27
Ich würde vor allem mal ein wirkliches Projekt rendern und das vergleichen, als irgendwelche Benchmarks.
So weit bin ich gerade noch nicht. Jungfräuliches Windows musste schon noch sein und ich war jetzt nen Abend lang mit BIOS resetten und Neustarts beschäftigt...
DDR4-3200 RAM muss bei Ryzens vom Grundtakt von 2133 MHz auf die theoretisch möglichen 3200 MHz übertaktet werden.
Geht dank xmp normalerweise problemlos, nur halt nicht immer mit 1,35 Volt stabil... Und schon hängt man in der O.C. Schleife, um überhaupt ein stabiles System zu haben. Ist wohl die Krücke bei den Ryzens.
Die RAM Riegel sind vermutlich doch nicht so gut gematcht und der Händler hat umsonst von der Hochwertigkeit geschwärmt.
Jetzt überleg ich halt, ob ich das HDD RAID mit umziehe oder gleich alles per SSD und NAS anbinde.

Aus einer Laune heraus landeten heute Nacht beide Grafikkarten im Rechner und kombiniert laufen beide auf dem Niveau einer 3090. Allerdings immer noch nur mit einer anderen Anwendung offen.
Wenn auf der Kiste footage und alle Anwendungen sind, schau ich mir natürlich die real Life Performance an.

Ahso:
Weil ich jetzt bequem zwischen den GPUs umschalten kann, kann ich sagen, dass die 3060er bis jetzt doppelt so schnell wie die 1070ti ist. BRAW scheint automatisch auf der Schwächeren der GPUs ausgeführt zu werden.




medienonkel
Beiträge: 414

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von medienonkel » Do 18 Aug, 2022 23:00

Um den Thread zu schließen, noch mein Fazit der Umrüstaktion:

Eine Workstation, die 2009 bei Dell vom Band fiel (2xXeon 5650 (12 Kerne/24 Threads, 72 GB RAM) ist einem nun auch schon 5 Jahre alten Ryzen 7 2700X (8Kerne/16 Threads) hoffnungslos unterlegen. Ryzen und RAM ist so eine Sache. Der erzielbare Speichertakt hängt stark vom Prozessor und dem Mainboard ab. "Silicone Lottery" nennt sich das dann. Alles über 2400 MHz Speichertakt gilt als Overclocking, auch wenn man 3200 MHz Speicher kauft.
Dennoch sind mit dem Speicher OC erstaunliche Leistungszuwächse möglich. (3000er Speicher läuft mit 2866 MHz stabil)

Die Mehrleistung beim für mich relevanten V-Ray durch OptiX sind schon signifikant. Dreifache Leistung bei RTX (3060) gegenüber CUDA (1070ti) waren die 400 Euro für die RTX 3060 durchaus wert.

Die Dell T5500 inkl. 1070ti sind jetzt zum zocken übrig geblieben. (Und als Backup System)

Der V-Ray Benchmark scheint irgend eine Macke zu haben- Nutzt die Grafikkarte nur voll, wenn eine andere Anwendung die GPU nutzt.




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von klusterdegenerierung » Fr 19 Aug, 2022 01:12

Ich hab tatsächlich in dem Zuge noch mal nachgesehen und meine CPU lief wieder auf Volllast und die GPU war auf 0, da sich wohl nach einem Nvidia update alle 3D settings zurückgesetzt haben.

Nach dem alles wieder umgestellt ist, geht die GPU bis auf 98%, Lüfter volle Leistung und CPU auf 30%.
Der Speicher je nach Einstellung. Wenn man also überhaupt in Resolve was von seiner GPU haben möchte, kommt man in Windows nicht um die settings drum rum, denn ansonsten ist sie quasi Arbeitslos. ;-)
"Niveau sieht nur von unten aus wie Arroganz!"




markusG
Beiträge: 2820

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von markusG » Fr 19 Aug, 2022 09:00

@kluster: hast du das ganze mal spaßeshalber mit den Studiotreibern verglichen?




medienonkel
Beiträge: 414

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von medienonkel » Fr 19 Aug, 2022 11:21

Ich nutze die Studiotreiber und da gibt es bei mir keine "3D Leistungs Einstellungen". OpenGL kann ich gezielt aktivieren, der Rest hat nix mit irgendeiner Art von Beschleunigung zu tun. Nur Antialiasing usw.
GPU wird trotz speziellen Settings voll genutzt.

Was ich auch festgestellt habe ist, dass je nach Windows Version die GPU-Leistung nicht richtig angezeigt wird. Erst, wenn man gezielt CUDA in der Anzeige im Taskmanager auswählt sieht man die Beanspruchung.

@Kluster: nutzt du die Gaming-Treiber?




Bruno Peter
Beiträge: 4245

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von Bruno Peter » Fr 19 Aug, 2022 11:37

klusterdegenerierung hat geschrieben:
Sa 06 Aug, 2022 18:42
Was Du aufjeden mal machen solltest, wenn Du es nicht eh schon machst und Windows verwendest, das Du in den Nvidia 3D Settings Resolve als Programm hinzufügst und die 3D Option aktivierst und auf Leistung stellst und den Gaming quatsch abstellst, erst dann verwendet Resolve Deine GPU wirklich, voher wird gerne nur die CPU verwendet, die dann bis auf 100% geht und die GPU wenn überhaupt auf vielleicht max 20%.
Ich habe es so vor zwei Jahren gemacht als ich mir einen neuen PC angeschafft habe mit der NVidia RTX 2060 Super.
Sie wird von tatsächlich von Resolve bis zu 100% genutzt bei anspruchsvollen FX-Filtern. Also ich bin damit vollkommen zufrieden.
** S8-Hobbyfilmer seit 1970, Video seit 1988, Schmalfilmdigitalisierer seit 2007 **
** Aktuelle Hauptkamera: Sony ZV-1 & Zhiyun Crane M2 Gimbal, HDR(HLG) 4K **
http://www.videoundbild.de/




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von klusterdegenerierung » Fr 19 Aug, 2022 11:41

medienonkel hat geschrieben:
Fr 19 Aug, 2022 11:21
Ich nutze die Studiotreiber und da gibt es bei mir keine "3D Leistungs Einstellungen". OpenGL kann ich gezielt aktivieren, der Rest hat nix mit irgendeiner Art von Beschleunigung zu tun. Nur Antialiasing usw.
GPU wird trotz speziellen Settings voll genutzt.

Was ich auch festgestellt habe ist, dass je nach Windows Version die GPU-Leistung nicht richtig angezeigt wird. Erst, wenn man gezielt CUDA in der Anzeige im Taskmanager auswählt sieht man die Beanspruchung.

@Kluster: nutzt du die Gaming-Treiber?
Vielleicht habe ich mich da unglücklich ausgedrückt! :-)
Ich nutze nur StudioTreiber, immer die neusten.

Du gehst in die Nvidia eigenen Systemsteuerung (Nvidia Icon in der Taskleiste)
Dort mußt Du unter "3D Einstellungen Verwalten" Das Programm Resolve hinzufügen und die settings selbst einstellen, wobei besonders wichtig die Cuda Einstellung "Alle" ist.

Ansonsten via Verstand vorgehen, also Gameing relevante Filter austellen, ansonsten was performance angeht, alles hoch drehen. :-)
PS. schau mal vorher in die GPU nutzung und nach den EInstellungen, Tag und Nacht! ;-)
Ich habe übrigens die Auto auswahl für Cuda und OpenGL in Resolve auf manuel Cuda gestellt, sicher ist sicher. ;-)
"Niveau sieht nur von unten aus wie Arroganz!"

Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.




dienstag_01
Beiträge: 11854

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von dienstag_01 » Fr 19 Aug, 2022 11:56

Standardmäßig ist CUDA immer an (globale Settings), da muss man also nichts dran ändern, auch nicht für Resolve.

Aber man kann natürlich an allem dran rumdrehen ;)




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von klusterdegenerierung » Fr 19 Aug, 2022 14:17

dienstag_01 hat geschrieben:
Fr 19 Aug, 2022 11:56
Standardmäßig ist CUDA immer an (globale Settings), da muss man also nichts dran ändern, auch nicht für Resolve.

Aber man kann natürlich an allem dran rumdrehen ;)
Global gesehen ist das Richtig, aber Resolve partizipiert nicht davon.
Erst dieses setting ermöglicht das Resolve volle Unterstützung bekommt.

Es ist ja nicht nur so das es eine an und aus Funktion gibt, sondern auch Abstufungen.
Wenn nun so eine eher niedrigere Abstufung auf Global steht, ist das für das Programm speziell gesehen eher weniger sinnvoll.

Vielleicht kann Mickey uns das besser erklären? :-)
"Niveau sieht nur von unten aus wie Arroganz!"




dienstag_01
Beiträge: 11854

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von dienstag_01 » Fr 19 Aug, 2022 14:37

klusterdegenerierung hat geschrieben:
Fr 19 Aug, 2022 14:17
dienstag_01 hat geschrieben:
Fr 19 Aug, 2022 11:56
Standardmäßig ist CUDA immer an (globale Settings), da muss man also nichts dran ändern, auch nicht für Resolve.

Aber man kann natürlich an allem dran rumdrehen ;)
Global gesehen ist das Richtig, aber Resolve partizipiert nicht davon.
Erst dieses setting ermöglicht das Resolve volle Unterstützung bekommt.

Es ist ja nicht nur so das es eine an und aus Funktion gibt, sondern auch Abstufungen.
Wenn nun so eine eher niedrigere Abstufung auf Global steht, ist das für das Programm speziell gesehen eher weniger sinnvoll.

Vielleicht kann Mickey uns das besser erklären? :-)
Das reimst du dir irgendwie zusammen, ist aber Unsinn.

Wenn ich wissen will, ob Cuda funktioniert oder nicht, dann schaue ich mir die Funktionen und Rechenzeiten in der jeweiligen Anwendung an, nicht im Taskmanager. Der Taskmanager kann einen Hinweis geben, ist aber nicht das Tool, um definitive Aussagen treffen zu können.




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von klusterdegenerierung » Fr 19 Aug, 2022 16:06

dienstag_01 hat geschrieben:
Fr 19 Aug, 2022 14:37
klusterdegenerierung hat geschrieben:
Fr 19 Aug, 2022 14:17


Global gesehen ist das Richtig, aber Resolve partizipiert nicht davon.
Erst dieses setting ermöglicht das Resolve volle Unterstützung bekommt.

Es ist ja nicht nur so das es eine an und aus Funktion gibt, sondern auch Abstufungen.
Wenn nun so eine eher niedrigere Abstufung auf Global steht, ist das für das Programm speziell gesehen eher weniger sinnvoll.

Vielleicht kann Mickey uns das besser erklären? :-)
Das reimst du dir irgendwie zusammen, ist aber Unsinn.

Wenn ich wissen will, ob Cuda funktioniert oder nicht, dann schaue ich mir die Funktionen und Rechenzeiten in der jeweiligen Anwendung an, nicht im Taskmanager. Der Taskmanager kann einen Hinweis geben, ist aber nicht das Tool, um definitive Aussagen treffen zu können.
Siggi, und wenn man dies nicht so macht wie beschrieben bleibt die GPU beim rendern auf 0% und wenn man es so macht geht sie auf 98%, ne ist klar.
Aber hey, es gibt eben immer so alles checker die recht behalten wollen, da machst Du es eben so und gut ist.
"Niveau sieht nur von unten aus wie Arroganz!"




Bruno Peter
Beiträge: 4245

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von Bruno Peter » Fr 19 Aug, 2022 17:04

Mache Dir nichts daraus, ich gebe Dir Recht weil ich mich ebenfalls
mit den Grafikkarten-Setting vor zwei Jahre schon befasst habe.
** S8-Hobbyfilmer seit 1970, Video seit 1988, Schmalfilmdigitalisierer seit 2007 **
** Aktuelle Hauptkamera: Sony ZV-1 & Zhiyun Crane M2 Gimbal, HDR(HLG) 4K **
http://www.videoundbild.de/




dienstag_01
Beiträge: 11854

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von dienstag_01 » Fr 19 Aug, 2022 18:33

klusterdegenerierung hat geschrieben:
Fr 19 Aug, 2022 16:06
dienstag_01 hat geschrieben:
Fr 19 Aug, 2022 14:37

Das reimst du dir irgendwie zusammen, ist aber Unsinn.

Wenn ich wissen will, ob Cuda funktioniert oder nicht, dann schaue ich mir die Funktionen und Rechenzeiten in der jeweiligen Anwendung an, nicht im Taskmanager. Der Taskmanager kann einen Hinweis geben, ist aber nicht das Tool, um definitive Aussagen treffen zu können.
Siggi, und wenn man dies nicht so macht wie beschrieben bleibt die GPU beim rendern auf 0% und wenn man es so macht geht sie auf 98%, ne ist klar.
Aber hey, es gibt eben immer so alles checker die recht behalten wollen, da machst Du es eben so und gut ist.
Wer weiß, an welchen Stellschrauben du ausserdem noch gedreht hast...
Man sieht ja, wo dieses hilflose Treiben hinführt: nach jedem Update geht das Spiel von vorne los. Absurd. Aber scheinbar gerne gemacht ;)




MK
Beiträge: 1952

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von MK » Fr 19 Aug, 2022 21:38

Was man noch direkt in Windows tun kann um die Grafikleistung etwas zu optimieren ist in die Grafikeinstellungen zu gehen (Windows 10 Suchfeld: Grafikeinstellungen) und dort die Hardwarebeschleunigte GPU-Planung einzuschalten und gegebenenfalls noch Anwendungen manuell in die Liste mit "Hohe Leistung" hinzufügen.

Der Geschwindigkeitszuwachs bewegt sich zwar wohl nur im 1-stelligen Prozentbereich (siehe auch https://www.pcgameshardware.de/Windows- ... t-1352947/), bei langwierigen Renderprozessen kann sich das am Ende aber trotzdem lohnen.




medienonkel
Beiträge: 414

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von medienonkel » Sa 20 Aug, 2022 11:32

klusterdegenerierung hat geschrieben:
Fr 19 Aug, 2022 11:41
medienonkel hat geschrieben:
Fr 19 Aug, 2022 11:21
Ich nutze die Studiotreiber und da gibt es bei mir keine "3D Leistungs Einstellungen". OpenGL kann ich gezielt aktivieren, der Rest hat nix mit irgendeiner Art von Beschleunigung zu tun. Nur Antialiasing usw.
GPU wird trotz speziellen Settings voll genutzt.

Was ich auch festgestellt habe ist, dass je nach Windows Version die GPU-Leistung nicht richtig angezeigt wird. Erst, wenn man gezielt CUDA in der Anzeige im Taskmanager auswählt sieht man die Beanspruchung.

@Kluster: nutzt du die Gaming-Treiber?
Vielleicht habe ich mich da unglücklich ausgedrückt! :-)
Ich nutze nur StudioTreiber, immer die neusten.

Du gehst in die Nvidia eigenen Systemsteuerung (Nvidia Icon in der Taskleiste)
Dort mußt Du unter "3D Einstellungen Verwalten" Das Programm Resolve hinzufügen und die settings selbst einstellen, wobei besonders wichtig die Cuda Einstellung "Alle" ist.

Ansonsten via Verstand vorgehen, also Gameing relevante Filter austellen, ansonsten was performance angeht, alles hoch drehen. :-)
PS. schau mal vorher in die GPU nutzung und nach den EInstellungen, Tag und Nacht! ;-)
Ich habe übrigens die Auto auswahl für Cuda und OpenGL in Resolve auf manuel Cuda gestellt, sicher ist sicher. ;-)
Hmmm. Also bei mir gibt es da keinen Unterschied, wie Tag und Nacht. Resolve nutzt bei mir auch ohne Sondereinstellungen die GPU voll aus.

Ich weiß auch nicht, was Gaming-Relevante Filter sein sollen. MSAA usw. packt Resolve ja nicht an.
Wie ich schon schrieb: Dass der Taskmanager eine GPU-Auslastung von 0% (3D Bechleunigung, Video, Copy....usw.) anzeigt, CUDA aber trotzdem mit 100% läuft, liegt am verkrüppelten Task-Manager. Bei der GPU-Leistungsanzeige kannst du bei den Unterkategorien ein Dropdown Menü öffnen und gezielt CUDA anzeigen lassen. Je nach Windows Version zeigt es die dann nicht nur in diesem gesonderten Fenster an, sondern wird dann auch in der allgemeinen GPU-Anzeige angezeigt.

Kann auch sein, dass deine CPU ne integrierte GPU hat und du da deshalb erst was aktivieren musst.
Aber hey, immerhin hast du eine Lösung für deine Hardware Kombi gefunden.

Keine Ahnung, vielleicht bin ich einfach schon zu alt für diese modernen EDV-Systeme und hol mir in Zukunft einfach ein Casablanca ;-)

Was tatsächlich meist immer 10% Leistungszuwachs bringt ist halt einfach schlicht und ergreifend Übertakten.




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von klusterdegenerierung » Sa 20 Aug, 2022 12:31

Die EInstellungen beziehen sich doch explizit auf die Nvidia Karte und die interne intel GPU ist nicht nur im Bios deaktiviert, sie verfügt auch über keine Cuda Unterstützung die sowohl in Resolve als auch in den 3D Einstellungen aktiviert sind.

Gaming relevante settings sind zb. Anti Aliasing und Text filterung etc. das sind für Resolve böhmisch Dörfer und kann man getrost abschalten.
Warum das bei Dir anders ist kann ich nicht sagen, bei mir und ich kenne noch andere User ist es so, das ohne diesese Einstellungen die GPU garnicht, oder nur mässig angesprochen wird.

Und immer dran denken, ich spreche hier explizit vom "rendern" denn das ist das was eine GPU übernehmen kann und sollte.
So sollte man also erstmal prüfen, ob zb. beim optimizing media eines Clips, nur die CPU zb. auf 100% jägt und die GPU nix macht, oder ob sie sich es teilen, oder wie im Fall mit den 3D Einstellungen, die GPU die volle Renderung übernimmt und die CPU mit ans Werk geht.

Alleine schon Akustisch ist dies eine andere Nummer, denn für gewöhnlich geht nur der Gehäuse Lüfter etwas mehr zur Sache, mit den Nvidia Settings hast Du aber plötzlich einen zusätzlichen GPU Fön am Start der in Volllast geht, den man ja sonst für gewöhnlich eher selten hört.

Das alleine sollte einem schon auffallen. :-)
"Niveau sieht nur von unten aus wie Arroganz!"




medienonkel
Beiträge: 414

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von medienonkel » So 28 Aug, 2022 19:29

Hmmm.... Also bei mir rendert die GPU immer, wenn ich in Resolve auf play drücke, oder an nem grade was drehe.
Zumindest ist die CPU auf zehn Prozent und die Timeline flutscht.

Und Föhn startet bei mir auch keiner, die Zeiten hab ich hinter mir gelassen

Wäre übrigens sehr schön, wenn Resolve das antialliasing von Nvidia nutzen könnte. Idr. Steuert die Software ja diese Einstellungen.

Aber gut, um Resolve ging's mir hier ja eigentlich auch nie :-)




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von klusterdegenerierung » So 28 Aug, 2022 21:44

Aha, Du redest über Resolve und postest Dein Thread im Resolve Menü, aber es ging ja die ganze Zeit nie um Resolve!
Ja ne, is klar.
"Niveau sieht nur von unten aus wie Arroganz!"




medienonkel
Beiträge: 414

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von medienonkel » Mo 29 Aug, 2022 14:33

Meine Güte...

Steht doch alles in meinen Posts, worum es ging. Du kamst halt irgendwann nur mit deinen Einstellungen für die GPU ums Eck, damit Resolve angeblich endlich die GPU nutzt.

Auf meine eigentliche Frage kam von dir ja gar nix :-)

Du machst mit deinem Rechner scheinbar nichts anderes, als Resolve drauf laufen zu lassen.

Aber passt schon, hab mir meine Fragen einfach alleine beantwortet.




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von klusterdegenerierung » Mi 31 Aug, 2022 09:17

Ich rendere gerade 4K in Voukoder und habe die Nvidia 3D Resolve settings etc. rausgenommen.
Schaue Dir mal den screenshot an, wenn ich es aktiviert habe, sieht dies genau umgekehrt aus und so wie jetzt kann ich nichts mit dem Rechner anfangen.
"Niveau sieht nur von unten aus wie Arroganz!"

Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.




medienonkel
Beiträge: 414

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von medienonkel » Mi 31 Aug, 2022 17:39

Okay.
Also geht's jetzt um die Performance beim Schnitt oder um den finalen export und das Finale encoding in nem neuen codec?
Wie sieht's denn ohne diesen Voucoder aus?

Falls ich mal wieder Lust und Zeit habe, schraub ich auch mal an den settings rum. Hab aber zur Zeit ne Arbeitsallergie.

Vray und Arnold jedenfalls rendern schneller als auf jeder 1080ti und wenn ich die CPU auch für CUDA aktiviere natürlich noch flotter.




Frank Glencairn
Beiträge: 16945

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von Frank Glencairn » Mi 31 Aug, 2022 20:00

medienonkel hat geschrieben:
Mi 31 Aug, 2022 17:39


Vray und Arnold jedenfalls rendern schneller als auf jeder 1080ti und wenn ich die CPU auch für CUDA aktiviere natürlich noch flotter.
Die CPU für Cuda aktivieren? Hab ich was verpasst?




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von klusterdegenerierung » Mi 31 Aug, 2022 20:27

Rendern halt, ist ja egal an welcher Stelle und wie, sobald encoded wird, sollte eigentlich auf die GPU zurückgegriffen werden, aber es gibt bei mir verschiedene Kombis, wo die GPU dies in Resolve nicht macht, bis ich Resolve zu den 3D settings in den Nvidia 3D Einstellungen hinzufüge.

Ob das dann wiederum was mit dem jeweiligen Codec etc. zu tun hat, gillt es natürlich auch noch rauszufinden.
Aufjedenfall scheint es bei mir anders als bei anderen Usern zu sein, oder den User fällt es nicht auf oder haben zufällig gerade eine Combi/config, wo die GPU auch ohne diese Einstellungen arbeitet.
"Niveau sieht nur von unten aus wie Arroganz!"




MK
Beiträge: 1952

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von MK » Mi 31 Aug, 2022 21:21

klusterdegenerierung hat geschrieben:
Mi 31 Aug, 2022 20:27
Ob das dann wiederum was mit dem jeweiligen Codec etc. zu tun hat, gillt es natürlich auch noch rauszufinden.
Was mich jedenfalls irritiert ist dass Resolve (bin noch bei der 17er) sich hier beim Umwandeln einer TIFF-Einzelbildsequenz (4K) nach ProRes (per Voukoder) 100% CPU-Last und 15% GPU gönnt...

Da ist kein Effekt oder sonst was drauf, Bildgröße, Framerate etc. auch 1:1. Ist das normal???




klusterdegenerierung
Beiträge: 23821

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von klusterdegenerierung » Mi 31 Aug, 2022 21:31

Hab ich mich auch gefragt.
Hast Du denn Resolve in 3D mit Cuda aktiv am Start?
"Niveau sieht nur von unten aus wie Arroganz!"




MK
Beiträge: 1952

Re: GPU Phänomen mit Resolve (und anderer CUDA Software)

Beitrag von MK » Do 01 Sep, 2022 03:42

Encoding 4K Tiff-Sequenz (Testbild) aus Resolve nach ProRes HQ mit Voukoder. Ergebnisse sind reproduzierbar, können auf anderen Systemen aber natürlich anders ausfallen. Grafikkarte ist eine RTX 3080 Ti in einem Dual-Xeon System mit 16 Cores / 32 Threads.

Resolve ist die letzte 17er Version. Angabe des höchsten in Resolve angezeigten FPS-Wertes und der niedrigsten und höchsten Werte für GPU und CPU im Windows Task-Manager innerhalb der ersten 2.5 Minuten Encodingzeit.

Ob sich die Gesamtzeit für den Export wesentlich ändert muss ich noch für den ganzen Film testen, die 23.5 fps fallen zeitweilig auch deutlich darunter (je nach Bildinhalt). Wie es sich mit der Gesamtzeit verhält reiche ich noch nach.

Was die CPU-Auslastung angeht habe ich das Gefühl dass in Resolve permanent eine Art Szenenerkennung mitläuft... bei harten Szenenwechseln schnellt die Auslastung beim Export teilweise auf 100% hoch.

Der ProRes-Encoder ist nicht GPU-beschleunigt und sollte daher nicht von der höheren GPU-Auslastung profitieren. Was auch immer da in Resolve beim 1:1 Export noch mitrödelt anscheinend schon.



Kein Eintrag in den Windows Grafikeinstellungen und kein Eintrag in Nvidia Systemsteuerung:

Max. 13.5 fps
GPU 6 - 14%
CPU 45 - 76%
Stromverbrauch 395 Watt


Eintrag Hohe Leistung in den Windows Grafikeinstellungen und kein Eintrag in Nvidia Systemsteuerung:

Max. 14.5 fps
GPU 7 - 16%
CPU 41 - 66%
Stromverbrauch 401 Watt


Eintrag Hohe Leistung in den Windows Grafikeinstellungen und Eintrag in Nvidia Systemsteuerung Energieverwaltungsmodus Maximale Leistung bevorzugen:

Max. 23.5 fps
GPU 2 - 100%
CPU 60 - 79%
Stromverbrauch 556 Watt




Social Media

       
 Aktuelle Beiträge [alle Foren]
 
» Was schaust Du gerade?
von cantsin - Mo 13:27
» Rodenstock Digital Vario ND EXTENDED 82mm für 30 Eur?!
von cantsin - Mo 12:54
» S1H - Ninja V - Probleme
von prime - Mo 12:47
» Premiere 2019 DRINGEND gesucht
von MrMeeseeks - Mo 11:36
» Asterix & Obelix im Reich der Mitte (Astérix & Obélix: L'Empire du Milieu) — GC
von 7River - Mo 10:23
» 9 Jahre mit der original BMCC
von Darth Schneider - Mo 5:49
» Nach dem Trailer zu urteilen, könnte der doch was werden
von Map die Karte - Mo 5:31
» Panasonic S5 - Allgemeine Fragen, Tipps und Tricks, Zeig deine Bilder/Videos usw.
von roki100 - Mo 2:06
» Was hörst Du gerade?
von klusterdegenerierung - So 23:36
» Neue Nvidia RTX 6000 Profi-Grafikkarte: 48 GB VRAM und 18.176 CUDA Cores
von patfish - So 20:48
» Ein paar FCP / MacOS - Tricks
von Axel - So 19:29
» Neue Sony Cinema Line Kamera kommt demnächst - mit APS-C Sensor?
von rob - So 19:24
» >Der LED Licht Thread<
von freezer - So 14:16
» Marlowe — Neil Jordan/William Monahan
von Map die Karte - So 12:07
» Blackmagic MultiDock 2 Thunderbolt 2
von funkytown - So 12:05
» Vikings: Valhalla — Jeb Stuart
von Map die Karte - So 11:42
» Laowa 58mm f/2.8 2X Ultra-Macro APO Objektiv vorgestellt
von slashCAM - So 10:30
» Aktuelle APS-C/S35 DSLMs - FUJI X-H2s und Canon EOS R7 - Dynamik-Shootout
von iasi - So 9:30
» VFX leicht gemacht: mit KI Gesichter animieren und Stimmen synthetisieren
von roki100 - Sa 23:25
» Panasonic GH6: SSD-Aufzeichnung über USB
von Clemens Schiesko - Sa 22:03
» M. Night Shyamalans "Knock at the Cabin" - offizieller Trailer
von 7River - Sa 20:15
» Verkaufe Century Xtreme Fisheye
von eliawebde - Sa 19:45
» x-rite i1 Display Pro - jetzt color checker i1 pro
von FocusPIT - Sa 18:48
» Erster Kinosaal mit Dolby Cinema eröffnet in Deutschland
von iasi - Sa 18:15
» Mr. & Mrs. Smith — Donald Glover/Francesca Sloane/Phoebe Waller-Bridge
von Map die Karte - Sa 12:58
» Neue Nvidia RTX 4090: Doppelt so schnell wie RTX 3090 Ti - aber 1.949 Euro teuer
von cantsin - Sa 10:59
» DJI Osmo Mobile 6: Neuer Smartphone-Gimbal mit verbesserter Objektverfolgung
von Schwermetall - Sa 10:35
» Fujifilm X-H2S in der Praxis: 6.2K 10 Bit ProRes HQ, F-Log2 und Hauttöne, Video-AF uvm.
von Frank Glencairn - Sa 8:39
» Suche Netztteil für die alte BM Pocket
von funkytown - Fr 23:34
» ACR Änderungen für verbesserte Fuji Raws
von klusterdegenerierung - Fr 20:57
» Django — Leonardo Fasoli/Maddalena Ravagli
von Map die Karte - Fr 20:04
» Was lernst Du gerade?
von klusterdegenerierung - Fr 17:05
» Weimar klassisch international: Schloss Belvedere
von 3Dvideos - Fr 15:56
» Neue Firmware 4.0 für Sony FX9
von slashCAM - Fr 14:48
» Gerücht: Sony bringt APS-C-Cinekamera FX30
von Darth Schneider - Fr 14:47
 
neuester Artikel
 
FUJI X-H2s Canon R7 - Dynamic Shootout

Kürzlich sind die FUJI X-H2s sowie die Canon EOS R7 zu unserer Dynamik-Clip Sammlung gestoßen, auf die wir natürlich umgehend einen kritischen Blick werfen wollen. Liegt der Belichtungsspielraum der beiden S-35 Kameras "auf Augenhöhe"? weiterlesen>>